手机访问          
logo
Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web
更新时间:2016-09-19 17:33:57    1736次阅读 评论 0

java 部署项目时出现:

Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web


原因是:dynamic web module version 的版本偏高


处理步奏:

在eclipse的workspace里面找到该项目。

依次进入:.settings->org.eclipse.wst.common.project.facet.core.xml。

打开文件后

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <runtime name="Apache Tomcat v7.0"/>
  <fixed facet="wst.jsdt.web"/>
  <fixed facet="jst.web"/>
  <fixed facet="java"/>
  <installed facet="java" version="1.7"/>
  <installed facet="jst.web" version="3.1"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
</faceted-project>

将jst.web的版本改低一点。

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <runtime name="Apache Tomcat v7.0"/>
  <fixed facet="wst.jsdt.web"/>
  <fixed facet="jst.web"/>
  <fixed facet="java"/>
  <installed facet="java" version="1.7"/>
  <installed facet="jst.web" version="3.0"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
</faceted-project>


重启eclipse(编辑器)

然后再次部署服务器

发现项目能够被发布了


分享按钮 分类:java
  

create:2016-09-19    阅读量(1736) 评论( 0 )

返回顶部
登录评论
  ABOUT ME
头像
昵称零零一
博龄 { 58.5月 }
积分610
博主被推荐的文章
相关博文
推荐博文
    关于C#中的String replace
    c#中Load += new Syste
    truacate table 与dele
    Substring函数的使用方法
    php 破解简单防盗链
    循环调用方法
    如何对密码进行必须包含字母,数字,特殊字
    cp: 无法创建普通文件'/usr/lo
    SQL Server常用快捷键
    Mysql并发时经典常见的死锁原因
标签云
反馈 联系©2015-2016 2016 ©zhoubo15.cn 粤ICP备15029033号-1